keywords: ip pbx voip gateway gsm gateway



The forum is in read only mode.
× Questions about B100/200/400/800 ISDN BRI Cards

asterisk + B400p integration with legacy pbx

12 years 8 months ago #7014 by nics
I work in a small company, which uses a legacy pabx (auerswald commander basic). We wish to integrate asterisk in our current setup to cut bill costs.

Current setup: NT(BRI)->auerswald PBX->POTS EXTENSIONS

The setup we proposed: NT(BRI)->B400P+asterisk server->auerswald PBX->POTS

Will we be able to setup multiple msns with B400P to integrate asterisk with the old PBX(supports point to multipoint ISDN) so that we can use all the features of asterisk? We need the asterisk IVR to forward the calls to the pots extensions that are already defined in the commander basic pbx.
Does anyone have a similar experience?

Thank you in advance
12 years 8 months ago #7015 by Joe.Yung
I think this solution is possible, you need to set your connection like this:

NT(BRI)-->B400P(TE mode: ptmp)+asterisk server-->auerswald PBX--> POTS

TE mode; To implement this mode, you have to set the jumper settings. Please read our B400P's manual.

12 years 7 months ago #7087 by leon.sinko
I have similar question.

wan patton asterisk
(1) VIP <---> isdn <----> (2) B200P <----> analog, isdn NT , SIP phones

--> isdn phone (3)
--> isdn modem (4)

I have a ISDN slitter with connection on 2,3,4 - asterisk, isdn phone and isdn modem

When i plug cable in B200P TE port i have nois on caller side if asterisk is on (1). I heare something but
In phone (3) is voice normal.

Widouth the connection with B200P is voice in phone (1) ok.

I tried termination on TE 0 or 1. - same result
I use normal (not cros over) cable.

I'm new user. (How do I make a new topic?)

I live in Slovenia.

I have centos 5.6., B200P, A800P.

What shoud I do?

i] Last edited by leon.sinko at 2011-7-12 17:33 [/i
12 years 7 months ago #7088 by Joe.Yung

Regarding the noise, could you please enable the softecho and see if it would be better?

Or record an audio file by dahdi_monitor, then send it to us to analyze.

From you enclosure, I found you have two pieces of cards. Is there IRQ conflicting issue?

12 years 7 months ago #7089 by leon.sinko
I speak in phone (1) and ISDN phone (3) - not thrue asterisk.
ISDN phone 3 is not connectet to out port of asterisk in is connected on input with isdn spliter i used.
I cannot record an audio file by dahdi_monitor.
On asterisk is voice normal.
Only if I pick phone (3) not on asterisk is voice in (1) noisi (I understend nothing from 3), on phone (3) is normal voice.

When i instead of asterisk plug a isdn phone is also normal voice.
When I speak with phone (1) and asterisk IP phone is there normal sound !

dmesg shows:
dahdi: Telephony Interface Registered on major 196
dahdi: Version: 2.4.0
ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKD] -> GSI 3 (level, low) -> IRQ 3
before raise reset
OpenVox A800P version: 1.4
OpenVox A800P passed register test
Module 0: Installed -- AUTO FXO (FCC mode)
Module 1: Installed -- AUTO FXS/DPO
Module 2: Installed -- AUTO FXS/DPO
Module 3: Installed -- AUTO FXS/DPO
DC-DC cal has a surprising direct 107 of 0x01!
Module 4: Installed -- AUTO FXS/DPO
Module 5: Installed -- AUTO FXS/DPO
Module 6: Installed -- AUTO FXS/DPO
Module 7: Installed -- AUTO FXS/DPO
Found an OpenVox A800P: Version 1.4 (8 modules)
OPVXHW loaded
wcb4xxp 0000:00:0b.0: probe called for b4xx...
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
PCI: setting IRQ 10 as level-triggered
ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
wcb4xxp 0000:00:0b.0: Identified OpenVox B200P (controller rev 1) at 0001b400, IRQ 10
wcb4xxp 0000:00:0b.0: NOTE: hardware echo cancellation has been disabled
wcb4xxp 0000:00:0b.0: Port 1: TE mode
wcb4xxp 0000:00:0b.0: Port 2: NT mode
wcb4xxp 0000:00:0b.0: Did not do the highestorder stuff
dahdi_transcode: Loaded.
wcb4xxp 0000:00:0b.0: new card sync source: port 4
INFO-xpp: revision Unknown MAX_XPDS=64 (8*8)
INFO-xpp: FEATURE: without BRISTUFF support
INFO-xpp: FEATURE: with sync_tick() from DAHDI
INFO-xpp_usb: revision Unknown
usbcore: registered new driver xpp_usb
dahdi: Registered tone zone 0 (United States / North America)
dahdi: Registered tone zone 9 (Austria)
-- Setting echo registers:
-- Set echo registers successfully
Bluetooth: HIDP (Human Interface Emulation) ver 1.1
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
buffer re-sync occur from 0 to 3
i think it is not the same irq .

Sorry, i have not yet figured out how to set the soft echo.
12 years 7 months ago #7091 by Joe.Yung

To enable soft echo, you need to go forward file /etc/dahdi/system.conf. Remove the # sign at the beginning of each parameter echocanceller.

Meanwhile, to make more progress, would you mind sending invitation to my IM: Gtalk: This email address is being protected from spambots. You need JavaScript enabled to view it. or This email address is being protected from spambots. You need JavaScript enabled to view it.?

Time to create page: 0.048 seconds
Powered by Kunena Forum